Please login or register.

TinyPortal - simple content managment for SMF

News: “Flying is like good music: it elevates the spirit and it's an exhilarating freedom. It's not a thrill thing or an adrenaline rush; it's engaging in a process that takes focus and commitment." - Harrison Ford

Author Topic: Bug: the NEW icon doesn't always bring up the new posts  (Read 1355 times)

0 Members and 1 Guest are viewing this topic.

Pegasus

  • Hero Member
  • *****
  • Posts: 848

Bug: the NEW icon doesn't always bring up the new posts
« on: June 24, 2011, 12:44:16 AM »
I clicked on the Pacific Northwest Airports link because the child boards showed some unread posts. In this view, all the various airports are all run together and you can pick out the ones in bold to click on.

Eastsound was bold, showing it had new posts, so I clicked on the NEW icon at the end of the airport name. That brought up a page that said: No unread topics found since your last visit. Click here to try all unread topics. Instead, I clicked back to the Pacific Northwest Airports and clicked Eastsound itself rather then the NEW icon. This brought up the four posts under that topic and the second one (the Madrona Bar and Grill) had an unread post. Clicking the NEW icon for that topic brought up the post.

Since it happened once, I tried it again. Easton had the same issue, but Burlington/Mount Vernon didn't (it worked correctly for that airport).

I'm using a PC with Windows XP sp 3 and IE 8.

If I can get it to do it more consistently, I'll post the steps.

- Ed
A good landing is one you can walk away from,
A great landing is where you can reuse the airplane!
Often seen making hard landings at BFI and S50

davidh

  • Administrator
  • Hero Member
  • *****
  • Posts: 4948
  • Wishing I was out there flying instead of surfing.

Re: Bug: the NEW icon doesn't always bring up the new posts
« Reply #1 on: June 24, 2011, 07:14:09 AM »
Yeah, I have noticed some similar behavior myself, but I'm on the forum so much lately (often with multiple browser windows open) that I had assumed I might have confused and overwhelmed the way it counts things - but I don't have a good sense of exactly how it's slipping up.

Keep in mind that there are actually several different conditions that it's trying to display: unread posts since your last visit, unread posts (regardless of the dates), and unread topics ("threads"), so it's easy to get confused (it confuses me sometimes, too).  If you find a way to repeat the steps and can document that, it would be helpful (but don't knock yourself out - at some point there may just be an update to the forum software from the developers that may tweak this behavior).

Thanks.
David Herman
N6170T - 1965 Cessna 150E
Boeing Field, Seattle, WA

spyingpotato

  • Hero Member
  • *****
  • Posts: 714
  • The Airport? What is it?

Re: Bug: the NEW icon doesn't always bring up the new posts
« Reply #2 on: June 24, 2011, 01:21:48 PM »
I will venture to guess the "unread" portion plays alot with cookie exchanges.  On my work laptop, which always flushes all browsing history on exit, I never get any new topics without clicking the "unread posts since your last visit" link.   Win7 IE 8, mozilla does the same, and has the same history settings.    By this, I will also guess that if your cookies are empty it says no unread topics, then clicking the "since your last visit" goes to the server to see when you were last logged in and displays messages accordingly.  Does this BB have a setting for checking browser cache before checking local history cache?  If not, them what I'm saying probably isn't it.
Matt
Mountlake Terrace
'69 C-150